Altitude Game: Forums  

Go Back   Altitude Game: Forums > Altitude Support > Tech Support

Tech Support Trouble running the game? Found a bug? Post here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-07-2016, 06:01 AM
OpTiMuS OpTiMuS is offline
Junior Member
 
Join Date: Jun 2014
Location: asia
Posts: 7
Default Error : Failed to process map

it is almost a year since i played altitude so when i tried to join ball dojo it said failed to processs map i tried to join a different server it was running a football map and it worked only some maps are working for me and remaining all just say failed to process map can u guys do anyting about this here is a screenshot of the problem http://prntscr.com/b18m80
Reply With Quote
  #2  
Old 05-08-2016, 06:30 AM
CmdrNoval CmdrNoval is offline
Senior Member
 
Join Date: Jan 2012
Location: Indiana-US
Posts: 518
Default hmm...`

No idea Optimus...

That is my server, and all the map files are up-to-date, as far as I know.

We did have some file errors in the cache over the last few weeks...

I will refresh the cache again, and check my master map stash for fragmentation...

If you are playing via Steam, I would suggest you ensure your local files are up-to-date. Here are the instructions:

Right click "Altitude" in your library

Click on "Properties" in the drop down menu

Click on the "Local Files Tab"

Click on "Verify Integrity of Game Cache"

If you are running the stand-alone version of Alti:

There was at least one large patch while you were offline, including the addition of widescreen resolutions, amongst other changes...

My suggestion for a stand-alone would be a re-install, to ensure you have the latest version, before proceeding.
Reply With Quote
  #3  
Old 05-10-2016, 07:57 AM
OpTiMuS OpTiMuS is offline
Junior Member
 
Join Date: Jun 2014
Location: asia
Posts: 7
Default

i just reinstalled alti and its working fine now thanks for ur help .
Reply With Quote
  #4  
Old 01-30-2017, 10:17 PM
Oyster Oyster is offline
Senior Member
 
Join Date: Jul 2011
Location: In the ocean.
Posts: 325
Default

I just ran across this problem too. Turns out OneDrive in Win 10 was ****ing with permissions for random folders when it automatically started up on cpu launch.
For me, OneDrive changed the permissions of a random Altitude folder related to game assets so that I wasn't allowed access even though I am the administrator. What this was doing in game was kicking me out of the server every time a map tried to use an asset in that restricted folder.

I disabled OneDrive from automatically starting when I start my PC, then followed this guide (http://www.fixedbyvonnie.com/2014/01.../#.WI-6fn_w_B6) to take back control permissions of the folder that had been changed. After that, I reinstalled Altitude.

All is well now!

Last edited by Oyster; 01-30-2017 at 10:19 PM.
Reply With Quote
  #5  
Old 02-09-2017, 12:22 AM
VAN1SH1NG VAN1SH1NG is offline
Senior Member
 
Join Date: May 2011
Posts: 927
Default

You might try running Altitude as administrator. Right click shortcut or exe file and run as admin. If it works right click shortcut/exe -> Properties -> Compatibility tab -> check "Run this program as an administrator".

If there is a permissions error running a program as admin should allow access to files.
Reply With Quote
  #6  
Old 02-16-2017, 10:34 PM
Oyster Oyster is offline
Senior Member
 
Join Date: Jul 2011
Location: In the ocean.
Posts: 325
Default

Quote:
Originally Posted by VAN1SH1NG View Post
You might try running Altitude as administrator. Right click shortcut or exe file and run as admin. If it works right click shortcut/exe -> Properties -> Compatibility tab -> check "Run this program as an administrator".

If there is a permissions error running a program as admin should allow access to files.
I seem to still have the problem despite right clicking and running Altitude as an administrator.

It looks like it seems to happen randomly AFTER my computer idles long enough to turn my screen black. Also seems to lock me out of DOTA files too, rendering that game incapable of updating after an idling black screen.

Going to switch my computer to never fade to black upon idle and see where that leaves me...
Reply With Quote
  #7  
Old 02-17-2017, 10:59 PM
LewisH LewisH is offline
Senior Member
 
Join Date: Mar 2012
Location: Earth
Posts: 215
Default

An extract of the error:

Code:
INFO [2017-02-17 14:26:49,886] [main]: unpacking map to maps\cache\download\ball_midnight_pb.altx
ERROR [2017-02-17 14:26:49,896] [main]: Failed to process map
java.io.FileNotFoundException: maps\cache\download\ball_midnight_pb.altx\_extract.tmp (Access is denied)
	at java.io.FileOutputStream.open(Native Method)
So yeah, an intermitent permissions problem. One possibility is a hard drive issue.
Another is windows being stupid -- maybe try disabling UAC (Control Panel\User Accounts and Family Safety\User Accounts -> 'Change user account control settings' and move the slider to the bottom).

edit: My first thought was that some file path was exceding windows' limit, but that's not the case here at least.

edit2: If disabling UAC works, it might be worth narrowing it down to the specific feature of UAC, as it doesn't seem to be recomended that you run without it for a long time. One particular stack overflow answer suggests that setting "EnableLUA" to 0 in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Cur rentVersion\Policies\System" would allow administrators to access all files without a UAC popup, which might be what the problem is (UAC needs your explicit permission before it will let you access the files, but since it's alttiude trying to access them, rather than explorer, it just doesn't show the UAC prompt and denies it by default..)

Last edited by LewisH; 02-17-2017 at 11:09 PM.
Reply With Quote
  #8  
Old 02-18-2017, 07:02 AM
Oyster Oyster is offline
Senior Member
 
Join Date: Jul 2011
Location: In the ocean.
Posts: 325
Default

It also denies me permission outside of Altitude, like, when I try to access the specific folder from my desktop.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to process map tgleaf Tech Support 6 01-01-2014 10:31 PM
Can't end altitude process LewisH Tech Support 2 03-26-2013 09:23 PM
Fatal Error, server launcher failed, exiting lxyao Dedicated Server 7 11-12-2012 12:59 PM
Ugh, Failed to Import PNG corrado33 Map Making 5 08-30-2011 10:06 AM
Map Design Process Mandrad Map Making 0 03-05-2010 05:17 PM


All times are GMT. The time now is 05:23 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 Nimbly Games LLC