Altitude Game: Forums  

Go Back   Altitude Game: Forums > Altitude Support > Dedicated Server

Dedicated Server Discuss technical issues related to hosting your own servers.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-25-2009, 11:00 PM
eth eth is offline
Senior Member
 
Join Date: Jun 2009
Location: Hamar, Norway
Posts: 594
Default Server problems (sorry)

I really hate to do this, but after trying for 3 hours I'm pretty pissed and very confused. The problem is the usual I guess - no one but me can see it.

I've tried port forwarding ranges 27272-27276, and I've tried enabling UPnP(but it seems like even with it enabled, the server can't find it - I think? The log says something about UPnP gateway not found). I tried with UPnP on/port forwarding off, all combinations, but no dice. I also haven't the faintest idea why it says my IP is connected on port 5XXXX, isn't it supposed to be 27275/27276? Hope you guys can help me!

Here's the server log:

Quote:
[25 nov 2009 23:41:16,171] INFO: Loading ServerLauncher config: C:\zak\altitude\servers\launcher_config.xml
[25 nov 2009 23:41:16,265] INFO: Loading ban list: C:\zak\altitude\servers\ban_list.xml
[25 nov 2009 23:41:16,281] INFO: Configuring UPnP
[25 nov 2009 23:41:19,296] INFO: No UPnP gateway found
[25 nov 2009 23:41:19,328] INFO: Resolving update server vapornew.nimblygames.com
[25 nov 2009 23:41:19,343] INFO: Update server is 75.102.27.114:31383
[25 nov 2009 23:41:19,359] INFO: Initializing update module on local IP 0.0.0.0/0.0.0.0, UDP port 27275
[25 nov 2009 23:41:19,609] INFO: Initial update check result: LOCAL_VERSION_IS_UP_TO_DATE
[25 nov 2009 23:41:19,781] INFO: Initializing 'eths supersayan superserver' on UDP port 27276
[25 nov 2009 23:41:19,796] INFO: Starting server on port 27276
[25 nov 2009 23:41:19,984] INFO: Changing map: ffa_lostcity
[25 nov 2009 23:41:20,328] INFO: Starting 1 game servers
[25 nov 2009 23:41:20,328] INFO: Starting update poller
[25 nov 2009 23:41:20,328] INFO: [Data Transfer Since Launch] Outgoing: 0,000 GB, Incoming: 0,000 GB
[25 nov 2009 23:41:20,546] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 51,2 / 63,6 MB
[25 nov 2009 23:41:20,593] INFO: valid server hello response; remote IP is 88.91.59.164:52062
[25 nov 2009 23:43:20,546] INFO: [Data Transfer Since Launch] Outgoing: 0,000 GB, Incoming: 0,000 GB
[25 nov 2009 23:43:20,765] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 51,0 / 63,6 MB
[25 nov 2009 23:45:20,390] ERROR: INVALID SERVER KEEP LOGGED IN RESPONSE: Your IP is no longer valid. This is most likely because your server is behind a router/firewall. Enable port forwarding http://portforward.com
[25 nov 2009 23:45:20,656] INFO: valid server hello response; remote IP is 88.91.59.164:52114
[25 nov 2009 23:45:20,765] INFO: [Data Transfer Since Launch] Outgoing: 0,000 GB, Incoming: 0,000 GB
[25 nov 2009 23:45:20,968] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 50,9 / 63,6 MB
[25 nov 2009 23:47:20,968] INFO: [Data Transfer Since Launch] Outgoing: 0,000 GB, Incoming: 0,000 GB
[25 nov 2009 23:47:21,187] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 50,1 / 63,6 MB
[25 nov 2009 23:48:34,093] INFO: Changing map: tbd_lostcity
[25 nov 2009 23:49:20,593] ERROR: INVALID SERVER KEEP LOGGED IN RESPONSE: Your IP is no longer valid. This is most likely because your server is behind a router/firewall. Enable port forwarding http://portforward.com
[25 nov 2009 23:49:20,859] INFO: valid server hello response; remote IP is 88.91.59.164:52126
[25 nov 2009 23:49:21,187] INFO: [Data Transfer Since Launch] Outgoing: 0,000 GB, Incoming: 0,000 GB
[25 nov 2009 23:49:21,390] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 49,2 / 63,6 MB
Reply With Quote
  #2  
Old 11-25-2009, 11:06 PM
lamster lamster is offline
Administrator
 
Join Date: May 2008
Posts: 1,655
Default

Those strange ports indicate that your router is not forwarding the traffic correctly. What router model are you using? Are you certain that:
1) Port forwarding is enabled on the router
2) UDP Ports 27275,27276 are forwarded to the computer that is hosting the servers (on that server, do start -> run -> cmd -> ipconfig to see its ip address)
3) Router firmware is up to date?
Reply With Quote
  #3  
Old 11-25-2009, 11:17 PM
Karl Karl is offline
Administrator
 
Join Date: May 2008
Posts: 1,206
Default

Yep, either port forwarding is not set up correctly or your router doesn't work. Routers are very notorious for not working. You could try updating the firmware on it... but as I found with my DLink DIR-655 upgrading the firmware caused me more problems than it solved and I can't revert back .

So anyways the line:
[25 nov 2009 23:41:20,593] INFO: valid server hello response; remote IP is 88.91.59.164:52062

Tells us that port forwarding is not working or not set up because your remote IP port should be the same as your internal port of 27276.
Reply With Quote
  #4  
Old 11-25-2009, 11:30 PM
eth eth is offline
Senior Member
 
Join Date: Jun 2009
Location: Hamar, Norway
Posts: 594
Default

Thanks a lot for the help! I'm 99% sure I port forwarded correctly, but I guess I'll try again. My apache server runs fine with port80 forwarded. I'm on a thomson st780 - I haven't even remotely touched firmware, I'll try updating for sure. I know I forwarded the ports on the correct computer though(if that's what you meant?), I'm not THAT bad!(hopefully)

Will post back before I either succeed or commit seppuku.
Reply With Quote
  #5  
Old 11-25-2009, 11:40 PM
Karl Karl is offline
Administrator
 
Join Date: May 2008
Posts: 1,206
Default

So i found the manual for your router:

http://www.speedtouch.nl/docs/ST780sip_UserGuide.pdf

Looks like they call port forwarding "Game & Application Sharing"
Section 5.5.5 page 76

Yea, it looks like your router does support UPnP... maybe a firmware update will let Altitude detect it.

It also supports port forwarding so hopefully that manual will help you set it up correctly.

Last edited by Karl; 11-25-2009 at 11:44 PM.
Reply With Quote
  #6  
Old 11-25-2009, 11:46 PM
Karl Karl is offline
Administrator
 
Join Date: May 2008
Posts: 1,206
Default

Oh another possibility is my router requires a reboot for any port forwarding changes to take effect... it's possible you need to reboot your router after you make changes.
Reply With Quote
  #7  
Old 11-26-2009, 02:06 AM
eth eth is offline
Senior Member
 
Join Date: Jun 2009
Location: Hamar, Norway
Posts: 594
Default

Well, this is just getting weirder. I was pretty sure I hadn't ****ed up my port forwarding, so I installed the port checking program from portforward.com, and it said all the altitude ports were open. Since that program can send/receive packets on 27275/27276, I guess that means the router is ok, or what?

I still get an increasing port number on the server - it started out in the 5XXXX range, and now it's up to 62XXX. Seems to be incrementing with ~30 every time it reports an error.

Even if it's still the router, I can't install a firmware update on it.. apparently my ISP decided to modify it before shipping it to me, so if I install firmware directly from the vendor my connection gets screwed over. :@ I'll try restarting it tomorrow(3am here now.. afraid I'll wake the sleeping beasts). Anyway, much appreciation for the continued help :P

edit: restarting the router didn't help. Also, after the port number hit somewhere around 64XXX-65XXX, it rolled around back to 48XXX. Seems a little weird to me since that's around the max value of a short uint? Or it could just be a coincidence I guess :P

Last edited by eth; 11-26-2009 at 05:17 PM.
Reply With Quote
  #8  
Old 09-14-2011, 01:45 AM
(5) bot1998 (5) bot1998 is offline
Senior Member
 
Join Date: Aug 2011
Location: At my desk, filling out paperwork.
Posts: 101
Default

I can't figure this out. I'm normally good with computers, but my airport utility asks about private udp, public tcp, and so on which I don't know. I'm using an Imac with the latest version of airport utility and using an airport extreme. Here's the log:[13 Sep 2011 18:41:00,491] INFO: Loading ServerLauncher config from /Users/.Altitude/servers/launcher_config.xml
[13 Sep 2011 18:41:00,556] INFO: PID is 6794 [written to /Users.Altitude/servers/server_launcher.pid]
[13 Sep 2011 18:41:00,559] INFO: Reading commands from /Users/.Altitude/servers/command.txt
[13 Sep 2011 18:41:00,562] INFO: Logging server activity to /Users.Altitude/servers/log.txt
[13 Sep 2011 18:41:00,572] INFO: Loading ban list from /Users/.Altitude/servers/ban_list.xml
[13 Sep 2011 18:41:00,575] INFO: Loading dynamic command JSON definitions from /Users/.Altitude/servers/custom_json_commands.txt
[13 Sep 2011 18:41:00,576] INFO: Configuring UPnP
[13 Sep 2011 18:41:03,682] INFO: No UPnP gateway found
[13 Sep 2011 18:41:03,688] INFO: Resolving update server vapor.nimblygames.com
[13 Sep 2011 18:41:04,027] INFO: Update server is 75.102.27.114:31383
[13 Sep 2011 18:41:04,028] INFO: Initializing update module on local IP 0.0.0.0/0.0.0.0, UDP port 27276
[13 Sep 2011 18:41:04,199] INFO: Initial update check result: LOCAL_VERSION_IS_UP_TO_DATE
[13 Sep 2011 18:41:04,551] INFO: Initializing '(5) Bot1998's server' on UDP port 27277
[13 Sep 2011 18:41:04,555] WARN: Map rating file does not exist: servers/map_rating_27277.xml
[13 Sep 2011 18:41:04,556] INFO: Starting server on port 27277
[13 Sep 2011 18:41:04,586] INFO: Distributor is nimblygames
[13 Sep 2011 18:41:04,722] INFO: Changing map: tbd_channelpark
[13 Sep 2011 18:41:04,962] INFO: FPM: initializing bot on port 100001
[13 Sep 2011 18:41:04,973] INFO: FPM: initializing bot on port 100002
[13 Sep 2011 18:41:05,032] INFO: Initializing 'Altitude Server' on UDP port 27278
[13 Sep 2011 18:41:05,032] WARN: Map rating file does not exist: servers/map_rating_27278.xml
[13 Sep 2011 18:41:05,032] INFO: Starting server on port 27278
[13 Sep 2011 18:41:05,034] INFO: Distributor is nimblygames
[13 Sep 2011 18:41:05,057] INFO: Changing map: ball_volcano
[13 Sep 2011 18:41:05,189] INFO: FPM: initializing bot on port 100001
[13 Sep 2011 18:41:05,192] INFO: FPM: initializing bot on port 100002
[13 Sep 2011 18:41:05,198] INFO: Starting 2 game servers
[13 Sep 2011 18:41:05,198] INFO: Starting update poller
[13 Sep 2011 18:41:05,210] INFO: [Data Transfer Since Launch] Outgoing: 0.000 GB, Incoming: 0.000 GB
[port 27277] [13 Sep 2011 18:41:05,212] INFO: Handling join request from 0.0.0.0:100001 -> lb@1f<vaporId=00000000-0000-0000-0000-000000000000, nickName=Bot 1, loggedIn=true, ip=0.0.0.0:100001>
[port 27277] [13 Sep 2011 18:41:05,217] INFO: Adding client 'Bot 1' from 0.0.0.0:100001, playerId=0
[port 27277] [13 Sep 2011 18:41:05,225] INFO: Handling join request from 0.0.0.0:100002 -> lb@1f<vaporId=00000000-0000-0000-0000-000000000000, nickName=Bot 2, loggedIn=true, ip=0.0.0.0:100002>
[port 27278] [13 Sep 2011 18:41:05,226] INFO: Handling join request from 0.0.0.0:100001 -> lb@1f<vaporId=00000000-0000-0000-0000-000000000000, nickName=Bot 1, loggedIn=true, ip=0.0.0.0:100001>
[port 27277] [13 Sep 2011 18:41:05,229] INFO: Adding client 'Bot 2' from 0.0.0.0:100002, playerId=1
[port 27278] [13 Sep 2011 18:41:05,229] INFO: Adding client 'Bot 1' from 0.0.0.0:100001, playerId=0
[port 27278] [13 Sep 2011 18:41:05,230] INFO: Handling join request from 0.0.0.0:100002 -> lb@1f<vaporId=00000000-0000-0000-0000-000000000000, nickName=Bot 2, loggedIn=true, ip=0.0.0.0:100002>
[port 27278] [13 Sep 2011 18:41:05,230] INFO: Adding client 'Bot 2' from 0.0.0.0:100002, playerId=1
[port 27277] [13 Sep 2011 18:41:05,358] WARN: Your server ((5) Bot1998's server) is behind a firewall. Only players on your LAN will be able to join your server. Go to http://nimblygames.com/wiki/index.ph...ort_Forwarding for advanced firewall and router instructions
[13 Sep 2011 18:41:05,370] INFO: Update check result: LOCAL_VERSION_IS_UP_TO_DATE, free memory: 41.2 / 62.4 MB
[port 27278] [13 Sep 2011 18:41:05,393] WARN: Your server (Altitude Server) is behind a firewall. Only players on your LAN will be able to join your server. Go to http://nimblygames.com/wiki/index.ph...ort_Forwarding for advanced firewall and router instructions
[port 27277] [13 Sep 2011 18:41:05,451] INFO: valid server hello response; remote IP is 108.13.72.121:42766
[port 27277] [13 Sep 2011 18:41:05,451] WARN: Your server ((5) Bot1998's server) is behind a firewall. Only players on your LAN will be able to join your server. Go to http://nimblygames.com/wiki/index.ph...ort_Forwarding for advanced firewall and router instructions
[port 27278] [13 Sep 2011 18:41:05,470] INFO: valid server hello response; remote IP is 108.13.72.121:41829
[port 27278] [13 Sep 2011 18:41:05,471] WARN: Your server (Altitude Server) is behind a firewall. Only players on your LAN will be able to join your server. Go to http://nimblygames.com/wiki/index.ph...ort_Forwarding for advanced firewall and router instructions


Please help me, as I'm confused about how this is done.

P.S I modified just the paths to the folders for privacy(ex. My home folder, desktop, so on.) I hope that's okay.

Last edited by (5) bot1998; 09-14-2011 at 01:49 AM. Reason: Privacy
Reply With Quote
  #9  
Old 09-14-2011, 04:43 AM
Juin Juin is offline
Member
 
Join Date: Feb 2011
Location: Pyongyang, North Korea
Posts: 81
Default

Altitude Game: Server Instructions and The Default Port Forwarding Guide for the Apple AirPortExtreme might help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:04 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
2008 Nimbly Games LLC